Glibc errors with GEMPAK

Hi all,

We've recently upgraded all of our Linux boxes from FC1 (eek!) to RHEL4.
Recently, users have noticed that nmap2 crashes with a glibc error.
Googling mostly suggested upgrading glibc.  We currently have the most
recent RedHat-approved glibc installed (glibc-2.3.4-2.36).  I tried updating
to a more recent glibc (2.3.6-3) to no avail.  We've tried GEMPAK 5.9.1,
5.9.2, and 5.10.2 (using the Linux binaries provided by Unidata) to no
avail.  All of the other NTL programs (Garp, Nalarm, etc) work, just not
nmap2.  The error message received is below.  Any suggestions?

Thanks,
BC

*** glibc detected *** free(): invalid next size (fast): 0x1c245a50 ***
Abort (core dumped)


Reference information
uname: Linux devo.eas.purdue.edu 2.6.9-55.EL #1 Fri Apr 20 16:35:59 EDT 2007
i686 i686 i386 GNU/Linux
gcc: gcc-3.4.6-8
g77: gcc-g77-3.4.6-8
glibc: glibc-2.3.4-2.36


-- 
Ben Cotton, KC9FYX
Unix System Administrator
Department of Earth and
  Atmospheric Sciences
Purdue University
http://www.purdue.edu/eas/resources/it

CIVL 4212
O: 765 49-61546
C: 765 404-7986