Previous: Documentation and Support Next: Known Problems Table of contents Images Frames Unidata's Integrated Data Viewer > Overview

1.5 FAQ


1.0 General

1.1. What is the IDV?

A. The Integrated Data Viewer (IDV) is a framework for visualizing and analyzing geoscience data. The IDV release includes a Java™-based software library, and applications made from that software. It uses the VisAD library for data and display models as well as other Java utility packages. It was developed at the Unidata Program Center (UPC), part of the University Corporation for Atmospheric Research, Boulder, Colorado, which is funded by the National Science Foundation. The software is freely available under the terms of the GNU Lesser General Public License.

The IDV brings together the ability to display and work with satellite imagery, gridded data (primarily from model output), and surface, upper air, and radar data within a unified interface. The IDV "reference application" provides many of the standard 2-D data displays that other Unidata packages (e.g. GEMPAK and McIDAS) provide. It also provides 3-D views of the atmosphere and allows users to interactively slice, dice, and probe the data to create cross-sections, profiles, animations and value read-outs of multi-dimensional data sets. Computation and display of built-in and user-supplied formula-based derived quantities is supported as well. It includes an integrated HTML interface that can be used to create HTML based users interfaces to drive the displays, or to embed IDV displays and controls directly in an HTML document.


1.2. Is the IDV still under development?

A. Development of the IDV is ongoing at the UPC and as it progresses new features will be added and any problems/bugs will be fixed. The development will be driven by the needs of the community of users. Suggestions, comments and collaboration are welcomed and encouraged. The goal is to provide new and innovative ways of displaying and analyzing data, as well as provide the common displays that many users have come to expect.


1.3. I'm submitting a paper for publication and want to include a citation for the IDV. What reference should I use?

A. The following can be used as a citation:

Unidata, (year): Integrated Data Viewer (IDV) version IDV_version [software]. Boulder, CO: UCAR/Unidata. (http://doi.org/10.5065/D6RN35XM)

where year is the year in which the work being described was done and IDV_version is the version of the IDV used. For example:

Unidata, (2015): Integrated Data Viewer (IDV) version 5.1 [software]. Boulder, CO: UCAR/Unidata. (http://doi.org/10.5065/D6RN35XM)


1.4. When was the IDV created?

A. The IDV was first released in 2002. You can read about the early history of the IDV in this paper:
Murray, D., J. McWhirter, S. Wier, S. Emmerson, 2003: The Integrated 
    Data Viewer: a Web-enabled application for scientific analysis and 
    visualization. Preprints, 19th Intl Conf. on IIPS for Meteorology, 
    Oceanography and Hydrology.


2.0 Downloading and Starting with Web Start

2.1. I couldn't download the IDV. Is the server down?

A. Usually an inability to download the IDV and other Unidata software is due to a failure by your system to correctly identify itself to our server.

Both our server and the system trying to download Unidata software have a "name" (domain name or host name or server name) and an IP address. For example the address 128.117.140.62 is the same as the server with name unidata.ucar.edu.

As a security measure many servers only reply to requests from systems whose address can be matched to a name using "reverse lookup " - turning the numbers into a name.

"Forward lookups" find the IP address of any given host name. The reverse action is resolving IP addresses into host names. If our server cannot resolve the requesting system IP address into a name, no software will be sent to the requesting IP address. If you are having problems downloading the IDV from our server, check with your local system administrator to make sure that your machine has reverse lookup enabled. If not, download the IDV from a system that does.


2.2. When I first run IDV through Web Start, it asks me to accept a certificate? What should I do?

A. When you first download IDV through Web Start, you will see a message like:
This application is requesting unrestricted access to your local 
machine and network.

Do you want to install and run: Integrated Data Viewer 
Signed and distributed by: University Corporation for Atmospheric Research 
Publisher authenticity verified by: Thawte Premium Server CA

Caution: University Corporation for Atmospheric Research asserts 
that this content is safe. You should only install and run this application 
if you trust University Corporation for Atmospheric Research to make 
this assertion.
If you trust Unidata to make safe software, click the Start button


2.3. How can I get updates through Web Start?

A. When starting the IDV using Web Start, the latest version of all IDV code is found at the Unidata server, and it is automatically downloaded and installed if it is newer than the version you have on your system.


2.4. How can I change the amount of memory used by IDV through Webstart?

A. The amount of memory used by the IDV is hardcoded in the Web Start JNLP file that is used to launch the IDV. If you would like to run IDV via Java Web Start with a modified memory alloaction, simply right click on the "Click here to launch the IDV" link on the IDV's Web Start page and save the file (e.g., idv.jnlp) to a convenient location. Then, open this file with an editor (e.g., WordPad, gedit) and modify the line "<j2se version="1.6+" max-heap-size="1024m" /> to reflect your memory need. After saving, you need only to launch this .jnlp file to run IDV via Java Web Start with the modified memory allocation. Please see the FAQ item below for more information on changing the memory allocation.


2.5. How do I use the Web Start Applications Manager?

A. For more control of the Java Web Start IDV installation, use the Web Start Applications Manager. Launch the Applications Manager by clicking here. You will see the IDV listed in the Applications Manager panel. You can use the Applications Manager to start the IDV without going to the Unidata Java Web Start link. In addition, with the Applications Manager, it is possible to remove broken or out-of-date IDV installations (see following FAQ item.)


2.6. How do I remove and re-install the IDV from Java Web Start?

A. If your Java Web Start IDV installation is broken or out-of-date, remove it with the Applications Manager. The Applications Manager will have a panel showing "Integrated Data Viewer <version>" with an icon. Click to select it. Use the Remove (X) button located at the top of the panel. The IDV item be deleted.

In addition, it may be necessary to clear out Java Web Start cached resources. Delete the jar resources that are found beneath the Resources pull-down menu item (just below Applications menu item.)

Finally, reload the IDV from Unidata. Note that you can verify the version of the IDV in the Applications Manager panel. The "Integrated Data Viewer" item is listed with a version number after it.


2.7. How can I show the Java console when running with Web Start?

A. When you start the IDV using Web Start, you don't have a console window opened by default. You can enable the Java console through the Web Start Applications Manager. Bring up the Web Start Manager (Java Application Cache Viewer) as described above. Use the Edit->Preferences menu to bring up the Preferences dialog. Click on the Advanced Tab and expand the Java Console item in the tree. Select the "Show Console" option and then click the OK button. The next time you start the IDV with Web Start, you will get a console that will log messages. Messages are also logged to the IDV console. See the item below for information on using this feature.


2.8. Can I serve up JNLP bundles from my own web server?

A. You can save a bundle as a JNLP file by using a .jnlp extension in the File->Save As... menu dialog. Once you have the file, you can place it on your web server and create a web page that points to it. Your web server must identify this as a JNLP file, so if it doesn't already support this, you'll need to configure your Web server so that all files with the .jnlp file extension are set to the application/x-java-jnlp-file MIME type. Each Web server has a specific way in which to add MIME types. For example, for the Apache Web server you must add the following line to the .mime.types configuration file:
application/x-java-jnlp-file JNLP
Check the documentation for the specifics of your Web server.


3.0 Using the IDV

3.1. How can I tell if the IDV is busy doing something?

A. The lower right corner of the main IDV view window shows a box with progress bars when the IDV is busy making a display or doing anything. In the status bar at the bottom, messages will appear when the IDV is reading data from a server or disk. Also, while the displays are being created, there is usually a "please wait" notice in the lower left corner of the main display.


3.2. How can I save a display?

A. You can save images of displays as JPEG or PNG files or animations as Quick Time movies or animated GIF's. See Image Captures.

You can save particular IDV state with all displays, including data sources, displays, maps, map projection, view point, and color tables, by saving a "bundle" file with the File->Save As... menu, and naming a file. See Saving State with Bundles. A bundle file lets you reset the IDV to exactly the same state as before. The file can be emailed to others to recreate your IDV display, provided they have access to the same data source.

Using the favorite bundles with File->Save As Favorite... menu you can save and use several configurations which are retrieved with the Displays->Favorites menu.


3.3. How can I change the start-up settings?

A. You can customize many of the IDV properties through Edit->Preferences menu. The preference manager allows you to configure the many features of the IDV.

You can also create a default IDV state and save it off using the bundle facility. This allows you to override the preferences and also include datasets and displays to load when the IDV starts. To save a default bundle, use the File->Default Bundle->Save menu. See Saving State with Bundles.


3.4. How can I change the amount of memory available to the IDV?

A. By default, the IDV startup script (runIDV (Unix) or runIDV.bat (Windows)) tunes the amount of memory allocated to the IDV according to system parameters. On 64 bit computers, the memory allocation amount is 80% of the available RAM. On 32 bit computers, the amount is the minimum of 1.5GB and the available RAM minus 512MB.

In addition, users can change the memory settings in the Edit→Preferences, System tab. In order for these changes to take effect, the user will have to restart the IDV.

In rare circumstances, the IDV start script cannot determine the optimal amount of memory for the IDV. In this unusual case, the IDV start script allocates 512MB. The user can still go to the Edit→Preferences, System tab and adjust memory settings. Again, the user must restart the IDV in order for this to take effect.

In other exceptional situations, the user may still wish to override the automatic tuning mechanism. In the body of the runIDV script, there are instructions on how to achieve this change, although this should rarely be necessary.


3.5. How can I change the size of the IDV window?

A. You can save particular IDV set-up including map, projection, With the IDV running, move and re-size the display and data source windows to the arrangement you like. Save the "default bundle" with the File->Default Bundle->Save menu. When you next start the IDV the same arrangement will appear.


3.6. How can I reset the map projections?

A. When new data is displayed, the map projection will be automatically switched to match the native projection of the data. You can control this with the Projections->Auto-set Projection menu check-box. You may not want this, especially when you have set up a view of a particular area which will be lost when new data is loaded. Check it off if you don't want it.

You can switch an existing display to its native data set projection using the display control's View->Use Data Projection menu.


3.7. How can I set the default projection?

A. You can select a default map projection with the Projection Manager which is accessed from the Projections->New/Edit menu. Select one of the items in the Default pull down list. The default projection is overridden by a projection saved in the default bundle, and by resetting the map projection with new data if enabled. As a result, you may never see the default map projection. Make sure your default bundle has the default projection, and you have the menu item Projections->Auto-set Projection menu checked off. Choosing a default map projection is not necessary for good use of the IDV and you can ignore it if you like. It is often simpler to use default bundles.


3.8. How can I change the color table range?

A. Many displays have a color table controlling the colors of data values. A color table has a range of minimum and maximum data values. You can change the range for a display by right clicking on the color bar in the display's legend and selecting the Change Range... menu from the popup menu. For more information on controlling the color table, see the Color Table Editor documentation.


3.9. How can stop the IDV from asking if I really want to exit?

A. You can change many features of the IDV though the User Preferences dialog. Use the Edit->Preferences menu to bring up the dialog. On the General tab, uncheck the "Confirm Before Exiting" box to stop the IDV from asking if you want to exit.


3.10. When I set a color table transparent, why doesn't it show up that way?

A. Using transparency in a color display may give unexpected results. In general, only the last thing added can be fully transparent. If you have a display that is transparent, then add in a new display, you may not see it. The problem is caused by the lack of ordering in Java 3D. You can use the display control's View->Bring to Front menu to remove and re-add the display that you want to be transparent so it is last.


4.0 Data

4.1. What is Fast Rendering and when should I use it?

A. By default, the IDV will try to adjust the data renderings to account for projection seams. This is computationally intensive in some cases and slows down the display of data. When you set your preference to "Use Fast Rendering", the IDV will not try to account for the projection seams. If you are displaying data in its native projection, this will result in faster rendering of the data depiction. However, if you have several displays of data, each from a different data source and on a different projection, you may see anomalies in the displays (spurious lines, portions of images). At that point, you can turn off fast rendering for a particular display using the Edit->Properties menu of the Display Control for that display, or set your system preference back to not use fast rendering.


4.2. I have multiple Grib files, each holding a separate time. How do I animate these?

A. Normally the IDV does not try to merge the separate grid files, it just loads them up individually as separate data sources. You then have to create separate displays for each time step. Furthermore, in the IDV displays with just one timestep are always shown.

What you want to do is to select the multiple set of grib files in the File Chooser (using control or shift click) and then select "Aggregate Grids by Time" for the Data Source Type. This will try to aggregate the grid files on time and will produce one data source with a set of times.

Note: each grib file needs to be identical in terms of variables, projections, etc. They should only differ by time.


4.3. What is the difference between true wind vectors and regular wind vectors?

A. Some gridded data is produced with the wind components being relative to the model grid instead of the earth. The true wind vectors are rotated from the grid projection to actual (true) wind direction. For non-projected (i.e., lat/lon grids), grid relative is the same as true.


4.4. What is the difference between the Standard Atmosphere and logarithmic pressure to height conversion?

A. The IDV displays pressure surfaces by converting the pressure to a height in some reference system. There are two reference systems that come standard with the IDV - the U.S. Standard Atmosphere and a logarithmic conversion (also used in Vis5D). The U.S. Standard Atmosphere only computes conversions for pressures up to about 80 km. The logarithmic coordinate system uses the following equations:
      P = 1012.5 * e^( H / -7.2 )        (^ denotes exponentiation)
      H = -7.2 * Ln( P / 1012.5 )        (Ln denotes natural log)
so can be used for heights above 80 km.


4.5. Can I view WRF model output in the IDV?

A. The Weather Research and Forecasting (WRF) Model output can be viewed in the IDV. You have several options for displaying the data. The IDV will read the native, staggered netCDF output from WRF, however we recommend that you post-process the data first. Using the native format is computationally and memory expensive, since the IDV has to transform the data on the fly. It is strongly recommended that you use one of the available WRF post process programs (e.g., ARWPost, WRFPost) to destagger the grids and compute the standard meteorological variables on pressure or height coordinates. The IDV can read the GRIB (1 & 2), GEMPAK and Vis5D output from these post-process routines.


4.6. Can I view Level III Radar data in the IDV?

A. The IDV can load Level III radar products from remote ADDE and TDS servers using the Radar Choosers provided in the reference application. It can also read many of the Level III products (radial and raster) from disk using the Radar Files chooser.


4.7. Can I view Level II Radar data in the IDV?

A. The IDV can be used to create displays of WSR-88D Level II radar data. The Level II data is supplied as volume-scan files, each file having all data from one WSR-88D radar for all sweeps for one "time". Unidata Community sites can receive Level II data using the Unidata Local Data Manager (LDM). Archived Level II data is available from the National Climatic Data Center (NCDC).

The files should be stored on your file system with each station's files in a directory (folder) whose directory name is the station 4-character ID (e.g., KTLX for Oklahoma City). In some cases the data files do not have any location information in them and the IDV uses the directory name as a first guess at the station location.


4.8. Why do I get an error when I try to load radar data that I downloaded from NCDC?

A. There are few common problems that can cause this:
  1. The files are in a compressed tar file - Typically, when you download Level II data from NCDC, the files are in a compressed TAR file which holds the individual volume scans. You need to extract the volumes from the TAR file with utilities like tar, gunzip, WinZip into a directory as described in the previous FAQ item.
  2. You are using the Files chooser You should load the radar data using the Level II data chooser in the Data Source Chooser, not the Files chooser. In some cases, the files do not have any location information in them. The Level II data chooser allows you to associated a station location with the data file, using the directory name as a first guess.


4.9. When I try to read in my GRIB data, why do I get an ucar.grib.NotSupportedException?

A. For the IDV to read in GRIB data, it needs access to lookup tables for decoding the information in the data. The IDV comes pre-configured with most of the commonly used tables from NCEP, FNMOC, etc, but some GRIB data from regional centers may use tables other than the defaults. If the IDV does not have the necessary table, you will get the NotSupportedException. You can add in new tables by following the instructions in the User's Guide section on Adding in new GRIB tables.


4.10. How are grids resampled in the IDV?

A. The IDV uses two methods for resampling data - weighted average and nearest neighbor. These are the default sampling mode for VisAD which the IDV is based on. For any grid, the samples are organized in a topology, which may be triangles (Irregular2D), squares (Gridded2D), tetrahedra (Irregular3D) or cubes (Gridded3D). For target points the system finds which topology element contains the target. For nearest neighbor, it gets the values at the vertex of that containing topology element closest to the target point. For weighted average, its computes a weighted average of all vertices of that containing topology element, where the weights are bilinear in 2-D and trilinear in 3-D. (source: Bill Hibbard, SSEC)


5.0 Display/Video Cards

5.1. Do I need a special video card to run the IDV?

A. Your video card must support OpenGL (or Direct-X if you are using the Direct-X version of Java 3D). If you experience problems with IDV displays (sets of triangles, spurious lines, weird looking displays), make sure your video driver is up to date. See your system's documentation for how to check that.


5.2. The display goes grey or gets corrupted when I resize my IDV display. What's wrong?

A. ATI cards do not always play nicely with the OpenGL version of Java 3D under Windows. If you experience problems with corrupted displays (sets of triangles, spurious lines, weird looking displays) and have an ATI card and are running Windows, try the following:

  • Right click on the Windows Desktop and select Properties from the pop-up menu.
  • From the Settings tab, make sure the color quality is 16 bit.
  • Click the Advanced button and select the OpenGL tab. Depending on your card, either click the button for Force 16 bit buffer (or something like that) or click on the Compatibility settings button and click the "Force 16 bit" radio button.
  • Click the OK buttons to exit the Display Properties dialog.
  • Try the IDV again and see if it works better
  • If not, try using the Direct-X installer instead of the OpenGL installer.


5.3. The maps appear as a spider web of lines. What's wrong?

A. Starting with IDV 2.7, some computers are experiencing spurious map lines in their displays. This seems to be a graphics driver issue being tickled by a change in this and later versions. If you are experiencing this, please use the Edit->Preferences, System tab, uncheck the "Enable geometry by reference" option, click OK and restart the IDV. That should clear up the spurious lines.


5.4. I'm having problems with the OpenGL version under Windows. How can I run the Direct-X version Java 3D?

A. If you are using the version of Java 3D distributed with the IDV (1.3.2), you can switch between the OpenGL and Direct-X versions of Java 3D with a command line switch. If you are using runIDV.bat to start the IDV, edit that file and uncomment the appropriate line. If you have your own script for starting the IDV, add in the -Dj3d.rend=d3d option to your start line (before -jar or class name).


5.5. On 32-bit Windows, it appears as though the IDV starts up correctly but the Map View is blank (black) and I get this error: Java3d Warning: Fail to lock Vertex Buffer - D3DERR_DRIVERINTERNALERROR.

A. First, you will need to switch the Java3D backend from OpenGL to Direct-X. If you are using runIDV.bat to start the IDV, edit that file, uncomment the appropriate line for Direct-X and add the -Dj3d.d3dVertexProcess=software after the -Dj3d.rend=d3d option. If you have your own script for starting the IDV, add in the -Dj3d.rend=d3d -Dj3d.d3dVertexProcess=software options to your start line (before -jar or class name).


5.6. Does the IDV support 3D Stereo?

A. The Java 3D library which the IDV uses supports stereo on properly configured stereo devices. We have added the necessary code to allow stereo to work in certain configurations. At present, the Unidata Program Center does not have access to a stereo system like a GeoWall, so our experience testing with these systems is limited. You will need to modify the runIDV script to change the -Didv.enableStereo=false to be -Didv.enableStereo=true before starting the IDV. If your runIDV script does not have the -Didv.enableStereo=false argument in it then change:
command="java -Xmx512m -jar idv.jar $*"
to:
command="java -Xmx512m -Didv.enableStereo=true -jar idv.jar $*"

After doing this, if you bring up the IDV on a stereo device and it does not appear to be in stereo, use the Viewpoint Toolbar to set the display to a perspective view.


5.7. My stereo display only seems to use one eye of the glasses. How do I fix this?

A. Some stereo cards do not keep a separate Z-buffer per eye. If you are experiencing problems, try changing the line in the runIDV script to:
command="java -Xmx512m -Didv.enableStereo=true -Dj3d.sharedstereozbuffer=true -jar idv.jar $*"


6.0 Potential Problems

6.1. I get the error "Bad version number in .class file" on my Mac. What does this mean?

A. IDV 2.8 requires Java 6 and most systems have Java 6 as the default version. On Mac OS-X, prior to the Snow Leopard release (10.6), Java 5 is the default version of Java. If you are not running Snow Leopard, you will need to update your Java version. See the System Requirements for information on updating Java on Mac OS-X.


6.2. How do I connect to remote servers through my firewall?

A. If you have a firewall and you try to get data from the remote servers (image, radar, point, upper air and profiler data), you may get error messages such as "Error opening connection ... Operation timed out" or "No Data Available." For these servers to send data, your firewall software must allow connections on ports 112 (ADDE) and 8080 (THREDDS Data Server).


6.3. I get an error that starts something like "Unexpected Signal : 11 occurred at PC=0x6F79CE1" when starting the IDV under Linux. What does this mean?

A. If the error message also includes a line that is looking for a Library with "dri" in it's name (e.g.: Library=/usr/X11R6/lib/modules/dri/i915_dri.so), it means that you are trying to load the DRI library in your X server which is not compatible with Java 3D. You need to comment out the line:

    Load "dri"

in your X server configuration file (xorg.conf or XF86Config).


7.0 Reporting Problems

7.1. What kind of support does Unidata provide for the IDV?

A. Unidata provides support to the entire community of IDV users through software updates, documentation, discussion email lists, and searchable support archives. Unidata provides direct support for the IDV to institutions offering college-level courses for credit, and to non-profit institutions with education or research missions. For more information, see the Unidata Support web page:

http://www.unidata.ucar.edu/support/index.html


7.2. How do I report problems?

A. First, check this FAQ and the list of Known Problems to make sure this is a problem that has not yet been reported.

If you experience unexpected behavior from the IDV other than the known problems, please let us know. See the Reporting Errors to Unidata Support section of the manual for the procedures on how to do this.


7.3. How do I open the Error Logs Console?

A. Open a console to show error logs with the Help->Show Console menu.


7.4. What information does the IDV send to Unidata

A. There are 2 things that Unidata may receive when you run the IDV. First, the IDV can access a number of resource files from the Unidata web site (e.g., http://www.unidata.ucar.edu/software/idv/resources/bundles.xml). Like any web access this is recorded by the web server access logs and no personally identifying information is recorded beyond the IP address.

When you submit a support request via the IDV information regarding the version of the IDV, the version of Java and the plugins you have installed is included in the support request.


7.5. The IDV has locked up and is not responding. What do I do?

A. First, we need to have you retrieve a stack track of the program so we can find out why this is happening. If you are running the most recent version of the IDV (after October 15th, 2008) the IDV provides a web-based service that produces a stack trace. Just view the URL:
http://localhost:8788/stack.html
and send the results to support-idv@unidata.ucar.edu. Note: this service is only available from browsers running on the machine the IDV is running on.

You can also use this service to shutdown the IDV.

If you are running an earlier version of the IDV you can:

On Windows do a control-break key in the IDV terminal window and copy/paste the result.

On Linux/Unix either do a control-/ in the terminal window or do a kill -3 <java process id>

To kill the IDV you can either close the windows or, if that does not work, remove (on Windows) the java.exe process through the Windows Task Manager or by killing the process on Linux/Unix.

At this time we're not sure how to do this on a Mac.

Java on SunOS is particular with its handling or 32 versus 64 bit architectures. See notes in runIDV script. You will have to add a -d64 JVM argument as is explained in the runIDV script. Please send question to support-idv@unidata.ucar.edu if you still have concerns.


 


Previous: Documentation and Support Next: Known Problems Table of contents Images Frames Unidata's Integrated Data Viewer > Overview