Dear netCDF community,
when I use Fortran netCDF to create a netCDF file with chunked data, I
have to options to do this:
(a)
nf90_def_var(ncid, VAR_NAME, NF90_INT, dimids, VARID)
nf90_def_var_chunking(ncid, VARID, NF90_CHUNKED, CHUNKSIZES)
(b)
nf90_def_var(ncid, VAR_NAME, NF90_INT, dimids, VARID, chunksizes =
CHUNKSIZES)
Option (a) seems to be consistent with respect to the C netCDF
functions. Additionally, one finds this option via the netCDF Fortran 90
Interface Guide:
https://www.unidata.ucar.edu/software/netcdf/netcdf-4/newdocs/netcdf-f90/
.
Option (b) is used in the Fortran netCDF test cases (when
installing/testing netCDF-F) and in this tutorial:
http://www.unidata.ucar.edu/software/netcdf/workshops/2011/nc4chunking/ChunkingExample.html
. However, it is not documented here:
https://www.unidata.ucar.edu/software/netcdf/netcdf-4/newdocs/netcdf-f90/NF90_005fDEF_005fVAR.html
The same situation prevails for deflating (nf90_def_var_deflate).
Is there a technical reason due to that I should prefer one of the two
options? Or is it just a question of personal taste and of the
readability of my code?
Kind Regards,
Daniel